BlackBerry (Contacts) has Multiple Desktop Address Books on Database

Overview
On the BlackBerry there are two different Desktop address books.  They are visible from Contacts > Options.  Some contacts exist only on the BlackBerry and will not synchronize to the mailbox.
 
 
Cause
The primary Address Book is empty and blocks the synchronization process.
 
 
Resolution
To resolve this issue, complete the following steps:
 
1.  Perform a full backup of the BlackBerry smartphone using BlackBerry Desktop Software.
 
2.  Wipe the BlackBerry smartphone data by following these steps:
 
a.  Go to Options > Security Options > General Settings.
 
b.  Press the Menu Key.
 
c.  Select Wipe Handheld.
 
3.  Ensure the wireless is off.  By default, the wireless is disabled after performing a security wipe.
 
4.  Connect the BlackBerry smartphone to BlackBerry Desktop Software.
 
5.  When prompted, choose the mail profile, which is linked to the Exchange mailbox of the BlackBerry smartphone user.
 
6.  Go to Backup and Restore > Advanced.
 
7.  Load the backup file that was created in Step 1 by going to Options > Open.
 
8.  From the left side, select the Address Book - All database, and then click the arrow pointing to the right and allow the request.
 
9.  Close the Backup and Restore window and click Synchronize.
 
10.  Make sure Synchronize organizer data is selected.
 
11.  In the Synchronization Configuration window, choose to synchronize only the Address Book.
 
12.  Setup synchronization with the user's Exchange mailbox.  Note: Some entries may be duplicated.  Duplicates should be deleted manually.
 
13.  Perform a wired synchronization process.
 
14.  When the synchronization process is complete, disconnect the BlackBerry.
 
15.  Wipe the device (repeat Step 2).
 
16.  Set the Enterprise Activation password for the BlackBerry user.
 
17.  On the BlackBerry, go to Options > Device > Advance System Settings > Enterprise Activation.
 
18.  Type the corresponding email address and the password.
 
19.  Let the BlackBerry activate.
 
20.  If necessary, restore any missing information from the full backup.  Note: Restore only the missing databases, do not use full restore.
 
The wireless synchronization should proceed as expected and the user should see only one Desktop contact list in Contacts > OptionsNote: If the user also uses BlackBerry Internet Service to receive personal emails, go to Options > Device > Advance System Settings > Default Services and ensure that Desktop is set as default service for email, calendar and contact list.
 
 
For Blackberry Desktop Software on a Mac computer:
 
1.  Perform a full backup of the BlackBerry using BlackBerry Desktop Software.
 
2.  Wipe the BlackBerry data by following these steps:
 
a.  Go to Options > Security Options > General Settings.
 
b.  Press the Menu Key.
 
c.  Select Wipe Handheld.
 
3.  Ensure the radio is not enabled. By default, the radio is disabled after performing a security wipe.
 
4.  Connect the BlackBerry to BlackBerry Desktop Software.
 
5.  Go to Restore.
 
6.  Select the backup file that was created in Step 1.
 
7.  Click Restore Selected data.
 
8.  Scroll down and select Address Book - All.
 
9.  Click Restore.
 
10.  Close the Backup and Restore window.
 
11.  Make sure that only the Address Book is selected for sync.
 
12.  Perform a wired synchronization process.
 
13.  When the synchronization process is complete, disconnect the BlackBerry
 
14.  Wipe the device (repeat Step 2).
 
15.  On the BlackBerry go to Options > Advance Options > Enterprise Activation.
 
16.  Type the corresponding email address and the password.
 
17.  Let the BlackBerry device activate.
 
18.  If necessary, restore any missing information from the full backup.  Note: Restore only the missing databases, do not use full restore.
 
The wireless synchronization should proceed as expected and the user should see only one Desktop contact list in Contacts > OptionsNote: If the user also uses BlackBerry Internet Service to receive personal emails, go to Options > Device > Advance System Settings > Default Services and ensure that Desktop is set as default service for email, calendar and contact list.
 
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